728x90
반응형
문제
정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 다섯 가지이다.
- push X: 정수 X를 스택에 넣는 연산이다.
- pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- size: 스택에 들어있는 정수의 개수를 출력한다.
- empty: 스택이 비어있으면 1, 아니면 0을 출력한다.
- top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력 1
14
push 1
push 2
top
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
top
예제 출력 1
2
2
0
2
1
-1
0
1
-1
0
3
예제 입력 2
7
pop
top
push 123
top
pop
top
pop
예제 출력 2
-1
-1
123
123
-1
-1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
|
import java.util.*;
public class Main {
public static void main(String args[]) {
Scanner sc = new Scanner(System.in); // 사용자 입력 스캐너
Stack<Integer> stack = new Stack<>(); // 스택 선언
int num = sc.nextInt(); // 명령의 수
for (int i = 0; i < num; i++) {
String order = sc.next(); // 사용자 명령어
if (order.equals("push")) {
int n = sc.nextInt();
stack.push(n);
}
else if (order.equals("pop")) {
if (stack.isEmpty()) {
System.out.println(-1);
} else {
System.out.println(stack.pop());
}
}
else if (order.equals("size")) {
System.out.println(stack.size());
}
else if (order.equals("empty")) {
if (stack.isEmpty()) {
System.out.println(1);
} else {
System.out.println(0);
}
}
else if (order.equals("top")) {
if (stack.isEmpty()) {
System.out.println(-1);
} else {
System.out.println(stack.lastElement());
}
}
}
}
}
|
cs |
[참고] 미리 구현된 Stack를 참고한 코드
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
|
import java.util.*;
public class Main {
public static void main(String args[]) {
Scanner sc = new Scanner(System.in); // 사용자입력
Stack<Integer> stack = new Stack<Integer>(); // 스택 선언
int input = sc.nextInt(); // 명령의 수
for (int i = 0; i < input; i++) { // 명령의 수만큼 반복
String comm = sc.next(); // 입력받은 명령어를 담기 위한 변수
if (comm.contains("push")) {
int data = sc.nextInt();
stack.push(data);
} else if (comm.equals("top")) {
System.out.println(stack.isEmpty() ? -1 : stack.peek());
} else if (comm.equals("size")) {
System.out.println(stack.size());
} else if (comm.equals("pop")) {
System.out.println(stack.isEmpty() ? -1 : stack.pop());
} else if (comm.equals("empty")) {
System.out.println(stack.isEmpty() ? 1 : 0);
}
}
}
}
|
cs |
728x90
반응형
'개발자였던 것 > 백준' 카테고리의 다른 글
[2739]구구단 (0) | 2020.11.17 |
---|---|
[14681]사분면 고르기 (0) | 2020.11.17 |
[2753]윤년 (0) | 2020.11.17 |
[9498]시험 성적 (0) | 2020.11.17 |